Jump to content
Sign in to follow this  
Talisman

Windows XP?

Recommended Posts

So, the SSG folks had to release a special client for Windows XP/Vista users.

Seriously, XP? Get a new computer.

Share this post


Link to post
Share on other sites

They made the wrong decision and should have just dropped support for both OSs.  XP is a security hazard, Vista is an unoptimized mess.

Share this post


Link to post
Share on other sites

It would have been nice if they had that sorted while both OS's were relevant.  I started out playing on XP and later Vista.  I agree that it's rather moot at this point, now that 7, 8 and 10 are currently mainstream.

Share this post


Link to post
Share on other sites

Awww, but that means the Heydts can no longer play.

Share this post


Link to post
Share on other sites
2 hours ago, LordVorontur said:

Awww, but that means the Heydts can no longer play.

Getting all the XP users out of the game would do wonders towards fixing that community.

Share this post


Link to post
Share on other sites

But Mrs. ODP spends more time lecturing the forums about elements of the game and lore that she has less than no clue about ....  and you could do that with a win95 rig

Share this post


Link to post
Share on other sites

Hey, it's about as bad as the people white-knighting for the XP users when the sad truth is the XP users should have upgraded a long time ago.  Also makes me wonder why I still care about that game, despite the community and gameplay giving me more than enough reasons not to.

Share this post


Link to post
Share on other sites

But somehow it's also weird that a game you bought suddenly can't be played anymore because your OS is outdated, while that OS was okay for years

Although MMO's are a 'weird' sort of game compared to other games.

 

I've got almost the same problem, I've updated my OS and have issues getting a game to run on Win 10. Game is almost 20 years old (Total Annihilation) and perfect for playing LAN-parties against my little brothers. Once I was the best of us 4, these days not anymore ;)

Share this post


Link to post
Share on other sites

A lot of the changes with the Windows 10 games that cause incompatibilities despite the game running fine on XP or 7 come down to the Windows driver stack/DirectX interactions or the user/admin permission difference.  The latter is what tends to be more problematic with XP era games, as enough of them would do stuff that makes solid performance sense, but not very secure (such as .NET code directly working with the driver stack - which is a bad idea for something intended to be user only).

Share this post


Link to post
Share on other sites

Wow... suggesting Turbine drops support of XP and Vista has really excited some people into resisting this move forward.

I'm completely and totally baffled by this exchange, as I would bet money that there's a high correlation between the segment of the population still on XP and Vista and the segment of the population that are not contributing financially to LotRO.

Share this post


Link to post
Share on other sites
4 hours ago, creonnoir said:

Rather than run XP or Vista install a good Linux distro ( https://www.linuxmint.com/ )  , and install wine-staging following the instructions at https://wine-staging.com/installation.html 

You can download and install the client then, everything just works, no hacks/fixes required.

However, if the type of person we're talking about that's still on XP or Vista is one that views a computer as an appliance, and doesn't understand WHY to upgrade, they're probably not going to have the technical knowledge to install Linux and Wine and get them both working.

Share this post


Link to post
Share on other sites

From https://www.lotro.com/forums/showthread.php?&postid=7734050#post7734050

Quote

We do not currently have a Bullroarer client available for Windows XP / Vista users. We hope to have one for the next preview weekend.

Well, it's a step in the right direction, and it's small incentive to get those users to upgrade.

I'd be more impressed if that client just happens to not show up, as it would demonstrate that SSG is doing the right thing and dropping XP and Vista support.

Share this post


Link to post
Share on other sites

It is perfectly reasonable to have a computer optimized for older games, and run Windows XP on that one.

Even some contemporary but underdeveloped games like LOTRO are single-threaded, so you would throw a computer with very high per-core speed at it. Such a computer could reasonably run Windows XP. Of course you never surf the web with it.

Share this post


Link to post
Share on other sites
6 hours ago, Darmokk said:

It is perfectly reasonable to have a computer optimized for older games, and run Windows XP on that one.

Even some contemporary but underdeveloped games like LOTRO are single-threaded, so you would throw a computer with very high per-core speed at it. Such a computer could reasonably run Windows XP. Of course you never surf the web with it.

Therein lies the paradox of LotRO... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×