Jump to content
LOTROCommunity
Sign in to follow this  
Darmokk

I really had it with the crap text box in IP.board

Recommended Posts

Most other forum software has "fancy textboxes" now but most of them are smart enough to offer you a basic one as a choice in the user preferences.

I really don't like what we have here. The textbox is just trash. Nothing works in there. Spellchecker is disabled - check. Platform keybinding are overwritten with useless trash - check. Browser extensions to use a regular text editor instead of the textbox are broken - check.

On Unix in particular it also completely breaks handling the X11 selection versus the X11 clipboard and cut'n'paste is essentially picking up random things. Now, I don't expect the author of a web application to be aware of any of these things. But I expect them to leave the hell the textbox alone so that they don't break it. Among all the forum software pieces that naively hack up textboxes they are the only ones to manage to really break this.

OK, I feel better.

Is there maybe a chance to submit a bug report and have them either fix some of the issues, or (much preferred) to use a plain dumb textbox from the browser?

Share this post


Link to post
Share on other sites

I've not really noticed any of these issues? What OS/browser are you using?

Share this post


Link to post
Share on other sites

Linux and FreeBSD firefox 18 and chrome, various versions.

Now that you asked I tried Chrome on mac and it works better. I guess these guys are hacking up things by try-and-erroring for the common platforms.

In any case, offering a plain browser textbox they didn't mess with should be an option for any forum software.

Share this post


Link to post
Share on other sites

You could try the "toggle edit mode" button in the topleft corner of the bar. That puts the editor in plain text mode.

Share this post


Link to post
Share on other sites

asdasd asdasdasdsad

You could try the "toggle edit mode" button in the topleft corner of the bar. That puts the editor in plain text mode.

No, same problems. All features disabled (no spellcheck, not recognized by extensions).

That's pretty absurd because I do have fine spellchecking (with my own dictionary) in here before those guys messed with it :)

Share this post


Link to post
Share on other sites

That's pretty absurd because I do have fine spellchecking (with my own dictionary) in here before those guys messed with it :)

I'm not sure what you mean. There's no built-in spellcheck in the editor? Try and see if you have the same issues on http://ckeditor.com/demo

Share this post


Link to post
Share on other sites

I'm not sure what you mean. There's no built-in spellcheck in the editor? Try and see if you have the same issues on http://ckeditor.com/demo

Right. Those textboxes disable spellchecking on Linux and FreeBSD, in Firefox and Chrome (to clarify, a plain browser textbox has it here). I see that it works on Mac.

I don't really mind the lack of spell-checking, but disabling browser extensions that deal with text fields is more of a big deal since I normally use extensions to fill out text boxes with external editors.

Share this post


Link to post
Share on other sites

I've just started using IE10 on Windows 7 and for some reason this text box keeps defaulting to a tiny font for me. Worked ok in IE9 and works fine in FF. Edit - Also carriage return doesn't seem do anything!

Share this post


Link to post
Share on other sites

They really, really, need to make a standard textbox that they didn't hack up a user-selectable option.

I see they fixed spell-checking in non-windows but that's just the tip of the iceberg.

Share this post


Link to post
Share on other sites

There is a new version of IPBoard out, I'll see if I can update it this week. Unfortunately, my time this week is limited, my girlfriends mother flies in today ;)

Share this post


Link to post
Share on other sites

The only issue i have with the editor is the insertion point indicator, every now and then it dissapears, it's still there but you can't see it and if you need to go back through your text to a certain point you have to guess wherre to stop it. i've found that similar issues on other forums and cms's i've worked on are usually some sort of java conflict somewhere on a page, i think this editor is the java scripted ckeditor right?

Share this post


Link to post
Share on other sites

I don't really care about fixes to the editor, it's too deep in the gutter. What is needed is a simple user preference to use a browser textbox instead.

That is what people often don't get. There is no long scream for endless rows of fixes and back and forth until it works right. A correctly working textbox is already built into the browser. It is dumb but works. Simply allowing people to use it is the one change to make.

(in the case of this board software things are worse than normal since they also disable browser extensions to use regular text editors, something that is not broken in other forums that also enriched their own textboxes)

Share this post


Link to post
Share on other sites

Pressing the button in the top left to remove the wysiwig elements and return it to plan text gets rid of the issues in IE10 for me (which unfortunately I am forced to use at work).

Share this post


Link to post
Share on other sites

Pressing the button in the top left to remove the wysiwig elements and return it to plan text gets rid of the issues in IE10 for me (which unfortunately I am forced to use at work).

That doesn't do anything about the stupidity of it. It now edits plain text but it's not a plain text box. Browser extensions still don't work. Cut'n'paste via the X11 selection (as opposed to clipboard) is still broken.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×